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ExchangeInfo Plus Overview 
 

ExchangeInfo Plus is a comprehensive database used for mapping and analyzing wire center serving 
areas and central offices throughout the United States and Canada. Wire center serving areas are the 
basic unit of geography in the telecommunications industry, describing the organization of local 
telephone exchange systems. ExchangeInfo Plus lists every LEC landline wireless center in the United 
States and Canada, and graphically displays their service areas.  

 

 
Figure 1 - ExchangeInfo Plus wire center serving area display 

 
Features 
 

In addition to providing geographic information about wire center serving areas, ExchangeInfo Plus also 
contains the following data about each wire center:  
 

• CLLI™ (Common Language Location Identifier) code 
• LATA assignment 
• Rate center names 
• Exchange names 
• Area codes (NPAs) 
• Prefixes (NXXs) 
• Carrier type information 
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Coverage and Projection 
 

ExchangeInfo Plus has the following coverage, scale, coordinates, and projection:  
 

Coverage United States, Guam, US Virgin Islands, US Northern Mariana Islands, and 
Canada 

Scale 1:24,000 

Coordinates Latitude and Longitude 

Projection NAD 83 

 

File Types 
ExchangeInfo Plus is supplied in MapInfo TAB file format. The file set can contain the following file 
types:  

 
Extension File Type 

.DAT Data file 

.ID Identification file 

.IND Index file 

.MAP Map file 

.TAB Tabular file 

 
 

In order to properly use ExchangeInfo Plus, the following rules apply:  
 

• You must have access to all of the files in the file set 
• All files must be located in the same directory.  

 

Installation 
 

Precisely recommends using MapInfo Pro version 7 or higher in conjunction with our 
telecommunication data products.  
 
To install ExchangeInfo Plus:  
 
1. Extract the contents of the compressed delivery file to a temporary folder location.  
 
2. Copy the contents of the Data folder to the desired destination folder. If the destination folder 

already contains a dataset of a previous vintage, be sure to use the Replace option to replace all 
files of the same name with files from the temporary location folder.  

 
3. Copy the contents of the Docs folder (product guide and release notes) to the desired destination 

folder.  
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4. Delete files from the temporary folder location.  
 
5. You are now ready to start using ExchangeInfo Plus.  

 

Document Conventions 
 

The following conventions are used throughout this document:  
 
Text Style Significance 

Underlined Emphasis 

Italics 
Document or chapter titles, or references 
to specific text 

Bold Field or file name references in text 

Text Style Significance 

Underlined bold Commands or actions 
Typewriter font, shaded 

background 
Keyboard input or screen output 

 
Field Names in Schema Tables 
 

Field names in schema tables are documented in upper-case letters. The appearance of field names in 
the actual product may differ from this convention.  
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File Structure 
 

ExchangeInfo is divided into five file sets:  
 

• Central office points (*Wcpt.*) 
• Wire center boundaries (*WcReg.*) 
• Area code and prefix data (*Npanxx.*) 
• Service type data (ServiceType.*) 
• OCN (operating company number) category data (OCNCategory.*) 

 
ExchangeInfo Plus File Sets  United States 
 

Central Office 
Point Files 

Wire Center 
Boundary Files 

Area Code and 
Prefix Data Files 

Service Type Data 
Files 

OCN Category 
Files 

UsWcReg.dat 
UsWcReg.id 
UsWcReg.ind 
UsWcReg.map 
UsWcReg.tab 

UsWcPt.dat 
UsWcPt.id 
UsWcPt.ind 
UsWcPt.map 
UsWcPt.tab 

UsNpanxx.dat 
UsNpanxx.ind 
UsNpanxx.tab 

ServiceType.dat 
ServiceType.tab 

OCNCategory.dat 
OCNCategory.tab 

 
ExchangeInfo Plus File Sets - Canada 
 

Central Office 
Point Files 

Wire Center 
Boundary Files 

Area Code and 
Prefix Data Files 

Service Type Data 
Files 

OCN Category 
Files 

CnWcReg.dat 
CnWcReg.id 
CnWcReg.ind 
CnWcReg.map 
CnWcReg.tab 

CnWcPt.dat 
CnWcPt.id 
CnWcPt.ind 
CnWcPt.map 
CnWcPt.tab 

CnNpanxx.dat 
CnNpanxx.id 
CnNpanxx.ind 
CnNpanxx.map 
CnNpanxx.tab 

ServiceType.dat 
ServiceType.tab 

OCNCategory.dat 
OCNCategory.tab 

 

ExchangeInfo Plus Data Schema 
 
United States Data 
 
US Central Office Points Table (UsWcPt) 
 

The Central Office Points table (point table) shows the geographical location of the central office for 
each wire center serving area in the US.  
 

Field Name Data Type 
(Length) Index Description 

WC_Code CHAR (8) Yes 8-character CLLI code for wire center 

V CHAR (5) No Vertical coordinate of central office 

H CHAR (5) No Horizontal coordinate of central office 
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Field Name Data Type 
(Length) Index Description 

X FLOAT No Longitude coordinate of central office 

Y FLOAT No Latitude coordinate of central office 

SOURCE CHAR (4) No 

Indicates how the point was created:  
 
ADDR – Geocoded LERG central office street 
address 
 
VH – LERG vertical and horizontal coordinates 
converted to latitude and longitude 
 
OTHR – Point created using other method 

 
US Wire Center Boundaries (UsWcReg) 
 

The Wire Center Boundaries table (region file) shows the geographic borders of wire center serving 
areas.  
 
Note: ExchangeInfo Plus US does not contain any geographic coverage data associated with wireless 
phone service.  
 

Field Name Data Type 
(Length) Index Description 

WC_CODE CHAR (8) Yes 8-character CLLI code for wire center 

 
US Area Code and Prefix Data Table (USNpanxx) 
 

The Area Code and Prefix Data table (data file) contains information about every NPA/NXX in service. 
 

Field Name Data Type 
(Length) Index Description 

NPA CHAR (3) Yes Area code 

NXX CHAR (3) Yes Prefix 

STARTRANGE CHAR (4) Yes 
For NPA/NXXs that have line range splits 
(thousand block pooling), this is the first number 
in the range 

ENDRANGE CHAR (4) Yes 
For NPA/NXXs that have line range splits 
(thousand block pooling), this is the last number 
in the range 

STATE CHAR (2) No State served by the NPA/NXX1 

WC_CODE CHAR (8) No 8-character CLLI code for wire center2 

SWITCH CHAR (3) No Last 3 characters of the CLLI code, indicating 
the switch that serves the NPA/NXX 
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Field Name Data Type 
(Length) Index Description 

SERVICETYPE CHAR (3) No Type of service provided by NPA/NXX. 

LATA CHAR (5) No LATA number 

OCN CHAR (4) No Operating company number3 

COMPANYNAME CHAR (50) No Name of the carrier assigned to the OCN, as it 
appears in the LERG 

OCNCATEGORY CHAR (10) No Type of carrier 

LOCALITY CHAR (10) No City name of the NPA/NXX 

EXCHANGE CHAR (24) No Exchange served by the NPA/NXX 

RATECENTER CHAR (16) No Rate center served by the NPA/NXX 

 
Notes: 
 

1 NPA/NXXs do not cross state lines.  
 
2 The 11-character CLLI code is divided across two fields in the database. The first 8 characters 
are shown in the WC_Code field. The remaining 3 characters are shown in the Switch field.  
 
3 In cases where carrier number local portability applies, there will be some subscribers in the 
NPA/NXX who are served by a different operating company. In such cases, the value listed in 
this field is the OCN of the company that “owned” the NPA/NXX prior to the number being 
ported to a different carrier.  

 
US Service Type Data Table (ServiceType) 
 

The Service Type data table (data file) provides service type descriptions. 
 

Field Name Data Type 
(Length) Index Description 

TYPE CHAR (3) No Service type 

DESCRIPTION CHAR (100) No Description of service type 

 
US OCN Category Data Table (OCNCategory) 
 

The OCN Category data table (data file) contains descriptions of OCN categories. 
 

Field Name Data Type 
(Length) Index Description 

CATEGORY CHAR (10) No OCN category 

DESCRIPTION CHAR (50) No Description of OCN category 
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Canadian Data 
 
Canadian Central Office Points Table (CnWcPt) 
 

The Canadian Central Office Points table (point file) provides the geographic location for each wire 
center servicing area.  
 

Field Name Data Type 
(Length) Index Description 

WC_Code CHAR (8) Yes 8-character CLLI code for wire center 

V CHAR (5) No Vertical coordinate of central office 

H CHAR (5) No Horizontal coordinate of central office 

X FLOAT No Longitude of central office 

Y FLOAT No Latitude of central office 

SOURCE CHAR (4) No 

Indicates how the point was created:  
 
ADDR – Geocoded LERG central office street 
address  
 
VH – LERG vertical and horizontal coordinates 
converted to latitude and longitude  
 
OTHR – Point created using other method  

 
Canadian Wire Center Boundaries Table (CnWcReg) 
 

ExchangeInfo Plus Canada does not contain any geographic coverage data associated with wireless 
phone service. ExchangeInfo Plus Canada contains geographic areas that have no telephone service. 
Each province containing this type of area will have a WC_Code designation with the province 
abbreviation followed by _UNS (ON_UNS in the case of Ontario, for example) in the CnWcReg.tab file. 
These WC_Code values are Precisely designated codes.  
 

Field Name Data Type 
(Length) Index Description 

WC_CODE CHAR (8) Yes 8-character CLLI code for wire center 
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Canadian Area Code and Prefix Data Table (CnNpanxx) 
 

The Area Code and Prefix Data table (data file) contains information about every Canadian NPA/NXX 
in service.  
 

Field Name Data Type 
(Length) Index Description 

NPA CHAR (3) Yes Area code 

NXX CHAR (3) Yes Prefix 

STARTRANGE CHAR (4) Yes 
For NPA/NXXs that have line range splits 
(blocked), this is the first line number in the 
range. 

ENDRANGE CHAR (4) Yes 
For NPA/NXXs that have line range splits 
(blocked), this is the last line number in the 
range. 

PROV CHAR (2) No Province served by NPA/NXX1. 

WC_CODE CHAR (8) No 8-character CLLI code for wire center2. 

SWITCH CHAR (3) No Last 3 characters of the CLLI code, indicating 
the switch that serves the NPA/NXX. 

SERVICETYPE CHAR (3) No Type of service provided by NPA/NXX. 

LATA CHAR (5) No LATA number 

OCN CHAR (4) No Operating company number3.  

COMPANYNAME CHAR (50) No Name of the carrier associated to the OCN, as it 
appears in LERG. 

OCNCATEGORY CHAR (10) No Type of carrier. 

LOCALITY CHAR (10) No City name of NPA/NXX. 

EXCHANGE CHAR (24) No Exchange served by NPA/NXX. 

RATECENTER CHAR (16) No Rate center served by NPA/NXX. 

 
Notes: 
 
1 NPA/NXXs do not cross province boundaries.  
 
2 The 11-character CLLI code is divided across two fields in the database. The first 8 characters are 
shown in the WC_Code field. The remaining 3 characters are shown in the Switch field.  
 
3 In cases where carrier number local portability applies, there will be some subscribers in the NPA/NXX 
who are served by a different operating company. In such cases, the value listed in this field is the OCN 
of the company that “owned” the NPA/NXX prior to the number being ported to a different carrier.  
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Canadian Service Type Table (ServiceType) 
 

The Service Type table (data file) provides descriptions of various service types.  
 

Field Name Data Type 
(Length) Index Description 

TYPE CHAR (3) No Service type 

DESCRIPTION CHAR (100) No Description of service type. 

 
Canadian OCN Category Data Table (OCNCategory) 
 

The OCN Category Data table (data file) provides descriptions of various OCN categories.  
 

Field Name Data Type 
(Length) Index Description 

CATEGORY CHAR (10) No OCN category 

DESCRIPTION CHAR (50) No OCN category description. 
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3  Using ExchangeInfo 
Pro 
 
 
 
 
 
 
 
 
 
 
 
In this section 
Selecting NPA/NXXs within a Wire Center 
Selecting Subsets of Central Office Points 
Selecting NPA/NXX Subsets 
Selecting All Boundaries for a Local Exchange Carrier 
Determining Service Wire Center Codes for a Customer Location 
Database 
Building Wire Center Boundaries for a State/Province 
Geocoding a Database of Phone Numbers Using Central Office 
Points 
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Selecting NPA/NXXs within a Wire Center 
 

To select the NPA/NXXs within a wire center boundary:  
 
1. Select a wire center boundary from the WcReg.map table using the Select tool.  
 
2. Click the wire center boundary using the Info tool. The Info tool window displays the eight-

character WC_Code value.  
 
3. Select the WC_Code.  
 
4. Select Edit > Copy, or press <CTRL> + C to copy the WC_Code.  
 
5. Select Query > SQL Select to open the SQL Select dialog.  
6. Enter UsNpanxx (or CnNpanxx, if querying Canadian data) in the from Tables field.  
 
7. Enter * in the Select Columns field.  
 
8. Enter WC_Code = in the where Condition field and press <CTRL> + V to paste the WC_Code into 

the field. Make sure that the WC_Code is enclosed in double quotes (e.g., “xxxxxxxx”).  
 
9. Leave the Group by Columns and Order by Columns fields blank.  
 
10. Enter Selection in the into Table Named field, as shown below:  
 

 
Figure 2 - Selecting NPA/NXXs within a wire center boundary 

11. Click OK.  
 
Query results will be displayed in a browser window.  
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Selecting Subsets of Central Office Points 
 

This section contains instructions for selecting the following subsets of central office points:  
 

• LEC landline central office points 
• CLEC central office points 
• Central office points that serve at least one wireless NPA/NXX 

 
Selecting LEC Landline Central Office Points 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsWcPt, UsNpanxx in the from Tables field.  
 
3. Enter UsWcPt.WC_Code, UsWcPt.V, UsWcPt.H, UsWcPt.Source in the Select Columns 

field.  
4. Enter UsWcPt.WC_Code = UsNpanxx.WC_Code and (UsNpanxx.OCNCategory = “RBOC” 

or UsNpanxx.OCNCategory = “ILEC”) and UsNpanxx.ServiceType = “EOC” in the 
where Condition field.  

 
5. In the Group by Columns field, enter UsWcPt.WC_Code.  
 
6. Leave the Order by Columns field blank.  
 
7. Enter Selection in the into Table Named field.  
 

 
Figure 3 - Selecting LEC landline central office points 

8. Click OK.  
 
Query results will be displayed in a browser window.  
 
Note: to query Canadian data, substitute Cn for Us in the statements above.  



 

ExchangeInfo Plus Product Guide 16 

Selecting CLEC Central Office Points 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsWcPt, UsNpanxx in the from Tables field.  
 
3. Enter the following in the Select Columns field: UsWcPt.WC_Code, UsWcPt.V, UsWcPt.H, 

UsWcPt.Source.  
 
4. Enter the following in the where Condition field: UsWcPt.WC_Code = UsNpanxx.WC_Code and 

UsNpanxx.OCNCategory = “CLEC”. 
 
5. Enter UsWcPt.WC_Code in the Group by Columns field.  
 
6. Leave the Order by Columns field blank.  

 
7. Enter Selection in the into Table Named field, as shown below:  
 

 
Figure 4 - Selecting CLEC central office points 

8. Click OK.  
 
Query results will be displayed in a browser window.  
 
Note: To query Canadian data, substitute Cn for Us in the statements above.  

 
Selecting Central Office Points that Serve at Least One Wireless NPA/NXX 
 

Note: Because central office points are not exclusively wireless, this query may return some LEC 
landline numbers served by these central office points.  
 
1. Click Query > SQL Select to open the SQL Select dialog.  
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2. Enter UsWcPt, UsNpanxx in the from Tables field.  
 
3. Enter UsWcPt.WC_Code, UsWcPt.V, UsWcPt.H, UsWcPt.Source in the Select Columns 

field.  
 
4. Enter UsWcPt.WC_Code = UsNpanxx.WC_Code and UsNpanxx.ServiceType <> “EOC” in 

the where Condition field.  
 
5. Enter UsWcPt.WC_Code in the Group by Columns field.  
 
6. Leave the Order by Columns field blank.  
 
7. Enter Selection in the into Table Named field, as shown below:  

 

 
Figure 5 - Selecting central office points that serve at least one wireless NPA/NXX 

8. Click OK.  
 
Query results will be displayed in a browser window.  
 
Note: To query Canadian data, substitute Cn for Us in the statements above.  

 

Selecting NPA/NXX Subsets 
 

This section provides instructions for selecting the following subsets of NPA/NXXs:  
 

• LEC landline NPA/NXXs 
• CLEC NPA/NXXs 
• Wireless NPA/NXXs 

 
Selecting LEC Landline NPA/NXXs 
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1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsNpanxx in the from Tables field.  
 
3. Enter * in the Select Columns field.  
 
4. Enter ServiceType = “EOC” and (OCNCategory = “RBOC” or OCNCateogry = 

“ILEC”) in the where Condition field.  
 
5. Leave the Group by Columns and Order by Columns fields blank.  
 
6. Enter Selection in the into Table Named field:  
 

 
Figure 6 - Selecting LEC landline NPA/NXXs 

7. Click OK.  
 
Query results will be displayed in a browser window.  
 
To query Canadian data, substitute Cn for Us in the statements above.  

 
Selecting CLEC NPA/NXXs 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsNpanxx in the from Tables field.  
 
3. Enter * in the Select Columns field.  
 
4. Enter OCNCategory = “CLEC” in the where Condition field.  

 
5. Leave the Group by Columns and Order by Columns fields blank.  
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6. Enter Selection in the into Table Named field:  
 

 
Figure 7 - Selecting CLEC NPA/NXXs 

7. Click OK.  
 
Query results will be displayed in a browser window.  
 
To query Canadian data, substitute Cn for Us in the statements above.  

 
Selecting Wireless NPA/NXXs 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsNpanxx in the from Tables field.  
 
3. Enter * in the Select Columns field.  
 
4. Enter ServiceType = “EOC” in the where Condition field.  
 
5. Leave the Group by Columns and Order by Columns fields blank.  
 
6. Enter Selection in the into Table Named field, as shown on the following page:  
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Figure 8 - Selecting wireless NPA/NXXs 

7. Click OK.  
 
Query results will be displayed in a browser window.  
 
To query Canadian data, substitute Cn for Us in the statements above.  

 
Selecting NPA/NXXs that Have Line Range Splits 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsNpanxx in the from Tables field.  
 
3. Enter * in the Select Columns field.  
 
4. Enter StartRange <> “0000” or EndRange <> “9999” in the where Condition field.  
 
5. Leave the Group by Column and Order by Column fields blank.  
 
6. Enter Selection in the into Table Named field, as shown on the following page:  
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Figure 9 - Selecting NPA/NXXs that have line range splits 

7. Click OK.  
 
Query results will be displayed in a browser window.  
 
To query Canadian data, substitute Cn for Us in the statements above. 

 

Selecting All Boundaries for a Local Exchange Carrier 
 

The query to select wire center boundaries for a particular local exchange carrier (LEC) can be based 
on either the company name or the operating company number (OCN). Both methods are detailed 
below.  

 
Selecting Boundaries by Company Name 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsWcReg, UsNpanxx in the from Tables field.  
 
3. Enter * in Select Columns field.  
 
4. Enter UsWcReg.WC_Code = UsNpanxx.WC_Code and UsNpanxx.CompanyName = 

“company_name” in the where Condition field. (Note: Replace “company_name” with the actual 
name of the company, surrounded by double quotes.) 

 
5. Leave the Group by Columns and Order by Columns fields blank.  
 
6. Enter Selection in the into Table Named field, as shown on the following page:  
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Figure 10 - Selecting LEC boundaries by company name 

7. Click OK.  
 
Query results will be displayed in a browser window.  
 
To query Canadian data, substitute Cn for Us in the statements above.  

 
Selecting Boundaries by Operating Company Number 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsWcReg, UsNpanxx in the from Tables field.  
 
3. Enter * in the Select Columns field.  
 
4. Enter UsWcReg.WC_Code = UsNpanxx.WC_Code and UsNpanxx.OCN = “####” in the 

where Condition field. (Note: Be sure to replace “####” with the actual OCN on which you’re 
querying, surrounded by double quotes.) 

 
5. Leave the Group by Columns and Order by Columns fields blank.  
 
6. Enter Selection in the into Table Named field, as shown on the following page:  
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Figure 11 - Selecting LEC boundaries by OCN 

7. Click OK.  
 
Query results will be displayed in a browser window.  
 
To query Canadian data, substitute Cn for Us in the statements above.  

 

Determining Service Wire Center Codes for a Customer Location 
Database 
 

Note: The following example assumes that customer locations are stored in a MapInfo Pro point table 
named Addresses, and that this table contains a column called WC_Code into which wire center 
codes will be written.  
 
1. Click Table > Update Column to open the Update Column dialog:  
 

 
Figure 12 - Update Column dialog 

 
2. Select the Addresses table from the Table to Update drop-down.  
 
3. Select UsWcReg from the Get Value from Table drop-down.  
 
4. Select Value from the Calculate drop-down.  
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5. Select WC_Code from the of drop-down.  
 

6. Select WC_Code from the Column to Update drop-down.  
 
7. Click the Join button. This displays the Specify Join dialog: 
 

 
Figure 13 - Specify Join dialog 

8. Check the where object from table UsWcReg radio button.  
 
9. Select contains from the object from table Addresses drop-down.  
 
10. Click OK. This returns you to the Update Column dialog.  
 
11. Click OK in the Update Column dialog.  
 
The Addresses table mentioned at the beginning of this subsection now contains the wire center cores 
that serve your customer locations. Wire center codes are displayed in the Addresses.WC_Code field.  

 

Building Wire Center Boundaries for a State/Province 
 

There are two methods for building a wire center layer for a particular state or province:  
 

• Finding wire center boundaries for all central offices in a state/province 
• Finding wire center boundaries serving all NPA/NXXs in a state or province 

 
Both methods are described in this section.  

 
Finding Wire Center Boundaries for Central Offices within a State/Province 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter UsWcReg in the from Tables field.  
 
3. Enter * in the Select Columns field.  
 
4. Enter Mid$(WC_Code, 5, 2) = “XX” in the where Conditions field, replacing “XX” with the 

two-letter state or province abbreviation, surrounded by double quotes.  
 
5. Leave the Group by Columns and Order by Columns fields blank.  
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6. Enter XXWcReg in the into Table Named field, replacing XX with the two-letter state/province 
abbreviation:  

 

 
Figure 14 - Finding wire center boundaries for central offices in a given state/province 

7. Click OK. Query results are displayed in a browser window.  
 
8. To save a copy of the wire center boundaries for the state or province, click File > Save Copy As 

…  
 
Finding Wire Center Boundaries Serving All NPA/NXXs in a State/Province 
 

1. Click Query > SQL Select to open the SQL Select dialog.  
 
2. Enter XxNpanxx in the from Tables field. Substitute Us for Xx if finding wire center boundaries for 

a state or Cn if finding them for a province.  
 
3. Enter * in the Select Columns field.  
 
4. Enter State = “YY” in the where Condition field, substituting the two-letter state or province 

abbreviation, enclosed in double quotes, for “YY”.  
 
5. Enter WC_Code in the Group by Columns field.  
 
6. Leave the Order by Columns field blank.  
 
7. Enter YY_WC_Codes in the into Table Named field, replacing YY with the two-letter state or 

province abbreviation:  
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Figure 15 - Query for building state/province wire center codes table 

8. Click OK. Query results are displayed in a browser window.  
 
9. Save a copy of the YY_WC_Codes table by clicking File > Save Copy As …, replacing YY with the 

two-letter state/province abbreviation.  
 
10. Click File > Open Table and open the wire center codes table you just created.  
 
11. Open the SQL Select dialog again by clicking Query > SQL Select.  
 
12. Enter XxWcReg, YY_WC_Codes in the from Tables field, replacing Xx with Us for a state or Cn for 

a province, and YY with the two-letter state/province abbreviation.  
 
13. Enter XxWcReg.WC_Code in the Select Columns field, replacing Xx with Us for a state or Cn for a 

province.  
 
14. Enter XxWcReg.WC_Code = YY_WC_Codes.WC_Code in the where Condition field. Substitute 

Us for Xx for a state or Cn for a province, and the two-letter state/province abbreviation for YY.  
 
15. Leave the Group by Columns and Order by Columns fields blank.  
 
16. Enter YYWcReg in the into Table field, replacing YY with the two-letter state or province 

abbreviation: 
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Figure 16 - Finding wire center boundaries for all NPA/NXXs in a state/province 

17. Click OK. Query results are displayed in a browser window.  
 
18. Save a copy of YYWCReg by clicking File > Save As Copy … 

 

Geocoding a Database of Phone Numbers Using Central Office Points 
 

This section outlines the process for using ExchangeInfoPlus to geocode a database that has a phone 
number field. Once finished, a map can be produced for each record in the source file. Mapped 
locations are based on the location of the central office point serving the NPA/NXX for a given number.  
 
Notes:  

• The following example uses an input file named Customers.tab, which contains the fields 
Name and Phone. The Phone field is formatted as NPA-NXX-XXXX, including dashes. The 
queries below need to be modified if the phone number field in your input file is formatted 
differently.  

 
• The queries below will also need to be modified to reflect the field names used in your input file.  

 
• To geocode Canadian addresses, substitute Cn for Us in the queries below.  

 
1. Click File > Open Table to open the input file in MapInfo Pro.  
 

 
Figure 17 - Sample geocoding input file 

2. Click Query > SQL Select to open the SQL Select dialog.  
 
3. Enter Customers in the from Tables field.  
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4. Enter the following in the Select Columns field: 
Name,Phone,Left$(Phone,3)”NPA”,Mid$(Phone,5,3)”NXX”,Right$(Phone,4)”Block

” 
 
5. Leave the where Condition, Group by Columns, and Order by Columns fields blank.  
 
6. Enter TempCustomers in the into Table Named field, as shown below:  
 

 
Figure 18 - Creating table for geocoding phone numbers using central office points 

7. Click OK. Query results will be displayed in a browser window.  
 
8. Save a copy of the TempCustomers table by clicking File > Save Copy As …  
 
9. Click File > Open Table and open TempCustomers.tab.  
 
10. Open the SQL Select dialog again by clicking Query > SQL Select.  
 
11. Enter TempCustomers, UsNpanxx, UsWcPt in the from Tables field.  
 
12. Enter TempCustomers.Name, TempCustomers.Phone in the Select Columns field.  
 
13. Enter the following condition in the where Condition field: TempCustomers.NPA = 

UsNpanxx.NPA and TempCustomers.NXX = UsNpanxx.NXX and TempCustomers.Block 

>= UsNpanxx.StartRange and TempCustomers.Block <= UsNpanxx.EndRange and 

UsNpanxx.WC_Code = UsWcPt.WC_Code 
 
14. Leave the Group by Columns and Order by Columns fields blank.  
 
15. Enter CustomerMap in the into Table Named field, as shown on the following page:  
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Figure 19 - Geocoding phone numbers using central office points 

16. Click OK. Query results will display in a browser window.  
 
17. Save a copy of CustomerMap by clicking File > Save Copy As …  
 
18. Delete the TempCustomers table by clicking Table > Maintenance > Delete Table …  
 
CustomerMap.tab contains your original data plus a geocoded point for each record in the database.  
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Acronyms 
This section lists the acronyms used in Precisely's telecommunications data products. Definitions of 
these terms are found in the Glossary section of this product guide.  
 
AHJ: Authority Having Jurisdiction 
 
ALI: Automatic Location Identification 
 
ANI: Automatic Number Identification 
 
CLEC: Competitive Local Exchange Carrier 
 
CLLI: Common Language Location Identifier; Wire Center Code 
 
CO: Central Office 
 
CRTC: Canadian Radio-television and Telecommunications Commission 
 
E9-1-1: Enhanced 9-1-1 
 
ESRD: Emergency Services Routing Digit 
 
ESRK: Emergency Services Routing Key 
 
FCC: Federal Communications Commission 
 
FIPS: Federal Information Processing Standard [codes] 
 
GIS: Geographic Information System 
 
ILEC: Incumbent Local Exchange Carrier 
 
LATA: Local Access Transport Area 
 
LEC: Local Exchange Carrier 
 
MSAG: Master Street Address Guide 
 
NPA: Numbering Plan Area; area code 
 
NXX: Prefix 
 
OCN: Operating Company Number 
 
PCS: Personal Communications Services 
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PSAP: Public Safety Answering Point 
 
PRCD: Province Code and Census Division [code] 
 
PSTN: Public Switched Telephone Network 
 
RBOC: Regional Bell Operating Company 
 
SQL: Structured Query Language 
 
V&H: Vertical and Horizontal [grid coordinates] 
 
VoIP: Voice over Internet Protocol 
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Glossary 
 

This section lists and defines terms used throughout this document and in Precisely's 
telecommunications data products.  

 
9-1-1 Service Area: The geographic area that has been granted by a state or local governmental body 
to provide 9-1-1 service.  
 
9-1-1 System: The set of network, database, and CPE (Customer Premises Equipment) components 
required to provide 9-1-1 service.  

 
Area Code: Also referred to as a Numbering Plan Area or NPA, the area code is a three-digit code 
designating a “toll” center in the United States or Canada. The first three digits of a telephone number 
(usually shown in parentheses) are the area code. For example, in the telephone number (412) 372-
2399, the area code is 412. 
 
Automatic Location Identification (ALI): The automatic display at the PSAP of the caller’s telephone 
number, the address/location of the telephone, and supplementary emergency services information.  
 
Automatic Number Identifier (ANI): The telephone number associated with the access line from 
which a call originates.  

 
Backup Public Safety Answering Point: Typically, a disaster recover answering point that serves as 
a backup to the primary PSAP and is not co-located with the primary PSAP. PSAP Pro does not 
contain Backup PSAPs.  
 
Basic 9-1-1: An emergency telephone system that automatically connects 9-1-1 callers to a designated 
answering point. Call routing is determined by originating central office only. Basic 9-1-1 may or may 
not support ANI and/or ALI.  

 
Call Routing: The capability to selectively route the 9-1-1 call to the appropriate PSAP.  
 
Cellular: The cellular radiotelephone service is a mobile radiotelephone service in which common 
carriers are authorized to offer and provide mobile telecommunications service for hire to the general 
public, using cellular systems. Cellular systems in the United States operate in 824-894 MHz frequency 
band and have 30 kHz channel spacing.  

 
Central Office (CO): A telephone company facility where a subscriber’s lines are joined to the 
switching equipment. This connects subscribers to each other for local and long distance service. The 
CO actually delivers the dial tone to the subscriber’s phone equipment. Each CO is assigned to a 
unique 11-character CLLI Code.  
 
Common Language Location Identifier (CLLI Code): Pronounced silly code, this is a code used to 
locate Wire Centers and switches. A wire center is assigned an 8-character CLLI Code; switches 
connected to a specific Wire Center are assigned an 11-character CLLI Code, the first 8 characters of 
which are the CLLI Code of the Wire Center.  
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Competitive Local Exchange Carrier (CLEC): A Competitive Local Exchange Carrier (CLEC) 
provides alternate service in areas served by either an RBOC or ILEC. CLECs are not required to 
provide service to all locations within their service territory and can decline to offer service to particular 
regions or consumers.  

 
E9-1-1: The wireless Enhanced 9-1-1 (E9-1-1) rules seek to improve the effectiveness and reliability of 
wireless 9-1-1 service by providing 9-1-1 dispatchers with additional information on wireless 9-1-1 calls. 
The wireless E9-1-1 program is divided into two parts: Phase I and Phase II. Phase I requires carriers, 
upon valid request by a local Public Safety Answering Point (PSAP), to report the telephone number of 
a wireless 9-1-1 caller and the location of the antenna that received the call. Phase II requires wireless 
carriers to provide far more precise location information, within 50 to 300 meters in most cases. The 
deployment of E9-1-1 requires the development of new technologies and upgrades to local 9-1-1 
PSAPs, as well as coordination among local public safety agencies, wireless carriers, technology 
vendors, equipment manufacturers, and local wireline carriers.  
 
Emergency Services Routing Digit (ESRD): Either a 10-digit North American Numbering Plan or non-
NANPA number that uniquely identifies a base station, cell site, or sector that is used to route wireless 
emergency calls through the network. The ESRD may also be used to retrieve ALI data associated with 
the call. These numbers can be dialable or non-dialable over the PSTN. PSPA Pro does not contain 
ESRDs. 
 
Emergency Services Routing Key (ESRK): Either a 10-digit North American Numbering Plan or non-
NANPA number that uniquely identifies a wireless emergency call. It is used to route the call through 
the network and retrieve associated ALI data. These numbers can be dialable or non-dialable over the 
PSTN. PSAP Pro does not contain ESRKs. 
 
Exchange Area: The geographic area in which telephone prices and services are the same. The 
concept of an Exchange is based on geography and regulation, not equipment. An Exchange might 
have one or more central offices and Wire Centers. A subscriber in the Exchange Area could get 
service from any of the central offices within the Exchange Area.  

 
FCC Registry: Information regarding PSAP ID, PSAP Name, and PSAP County can be obtained from 
the FCC’s Master PSAP Registry. PSAP Pro provides the related FCC PSAP ID for each PSAP in the 
US for which this information can be ascertained.  
 
Federal Communications Commission (FCC): The 9-1-1 Act directs the FCC to make 9-1-1 the 
universal emergency number in the United States for all telephone services, both wireline and wireless. 
Under FCC rules implementing the 9-1-1 Act, telephone companies and public safety organizations 
were expected to largely complete the transition to the use of 9-1-1 as the national emergency number 
by September 11, 2002. The FCC also directed telephone companies to file reports on their progress in 
implementing the transition to 9-1-1 under Public Notice DA 02-507. These reports are available online 
by searching for basic 9-1-1 carrier transition reports.  
 
Federal Information Processing Standards (FIPS) codes:  A standardized set of numeric or 
alphabetic codes issued by the National Institute of Standards and Technology (NIST) to ensure 
uniform identification of geographic entities throughout all US federal government agencies.  
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Geographic Information System (GIS): Computer applications, such as MapInfo Pro and 
CallingAreaInfo, that store and manipulate electronic maps and related data, are GIS applications.  

 
Inbound Local Calling Area: All the NPA/NXX combinations (and associated geographic area) that 
can call in to a given NPA/NXX by using a local phone service provider.  
 
Incumbent Local Exchange Carrier (ILEC): Telephone carriers that serve areas not served by 
RBOCs. In a given area there can be only one RBOC or ILEC offering service.  

 
License Area: Geographic area (MTA, BTA, CMA) that is obtained through an FCC auction in order to 
provide wireless communication at a specified frequency.  
 
Local Access Transport Area (LATA): The United States is divided geographically into 192 LATA 
regions. Local telephone companies are permitted to offer local or long distance telecommunications 
services within these regions. 
  
Local Exchange Carrier (LEC): A local telephone company which can be either a Regional Bell 
Operating Company (RBOC) or an independent. Also referred to as ILECs.  

 
Master Street Address Guide (MSAG): A database of street names and house number ranges within 
their associated communities, defining Emergency Service Zones (ESZs), along with the associated 
Emergency Service Numbers (ESNs) to enable proper routing of 9-1-1 calls. PSAP Pro does not 
contain MSAG information.  
 
Mobile Virtual Network Operator (MVNO): A company that buys network capacity from a network 
operator to offer its own branded mobile subscriptions and value-added services.  

 
Numbering Plan Area (NPA): Numbering Plan Area. 

 
Operating Company Number (OCN): A number used to identify a specific telephone company.  
 
Operating Company Number Name (OCN Name): The company name as shown in the Telcordia 
LERG database. 

 
Paging: A signaling and control channel which operates on a set of frequencies separate from those 
used to support cellular voice communications.  
 
Parent Company: Next-level-up ownership of OCN Name. This is an industry recognized company 
name that owns/operates multiple OCNs across the country.  
 
Personal Communication Services (PCS): Broadband Personal Communications Service (PCS) is 
used to provide a variety of services, such as digital mobile telephones and wireless Internet access. 
These services are also called mobile telephone services and mobile data services. PCS operates in 
the 1850-1990 MHz bands.  
 
Prefix (NXX): This term refers to the first three digits of a 7-digit local phone number. These first three 
digits refer to the number of the telephone company central office. 
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Primary PSAP: A PSAP to which 9-1-1 calls are routed directly from the 9-1-1 control office.  
 
Province Code and Census Division Code (PRCD): Used in the Canadian data table to specify the 
Province Code and Census Division Code in which a PSAP is located. This is comparable to the 
CountyFIPS in the US data table.  
 
Public Safety Answering Point (PSAP): The endpoint of an emergency services call. PSAPs are 
responsible for answering emergency 9-1-1 calls.  
 
Public Switched Telephone Network (PSTN): The international telephone system, based on copper 
wires carrying analog voice data.  

 
Rate Center: Rate Centers are geographic locations laid out according to telecommunications industry 
standards. The distance between two Rate Centers is used to calculate rates for telecommunications 
services between the two Rate Centers.  
 
Regional Bell Operating Company (RBOC): The term given to the 11 companies that were created 
from the initial divestiture of AT&T in 1984. After several mergers, there are currently 4 RBOCs.  

 
Secondary PSAP: A PSAP to which 9-1-1 calls are transferred from a primary PSAP.  
 
Selective Routing: The routing of a 9-1-1 call to the proper PSAP based on the caller’s location.  
 
Selective Transfer: The capability to transfer a 9-1-1 call to a response agency by operation of one of 
several buttons, typically designated as police, fire, and emergency medical.  
 
SQL: Structured Query Language. A powerful database language you can use to pull desired 
information from the CallingAreaInfo output database. By using various SQL commands, you can sort 
through the raw output and find the kinds of information you need for numerous applications.  

 
Trunk: Typically, a communication path between central office switches, or between the  
9-1-1 control office and the PSAP. PSAP Pro does not contain 9-1-1 trunks. 

 
V & H: Vertical and Horizontal grid coordinates. These numbers are assigned to locate each telephone 
company’s Central Office or Rate Center on a grid of the North American continent. Essentially, V & H 
are the “latitude and longitude” values of the telecom industry.  
 
Voice over Internet Protocol (VoIP): VoIP is a system for providing telephone service over the 
Internet.  

 
Wire Center: The location where a telephone company terminates local lines; this is usually the same 
location as a Central Office. A Wire Center might have one or more Central Offices. Because of this, 
the terms “Wire Center,” “Central Office,” and “End Office” are often used interchangeably.  
 
Wire Center Code (CLLI): A unique 8-character code assigned to each Wire Center.  
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Wire Center Servicing Area: The geographic extent of an Exchange Area served by a single Wire 
Center.  
 
Wireless Carrier: A cellular, PCS, or paging company that provides wireless voice or paging service. 
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Product Feedback and Support 
 

Contact our Support team (software.support@precisely.com) for product support and additional product 
information. You can also submit your innovative ideas or comment on existing submissions in a way 
that is visible to all participants via our Support site (https://support.precisely.com). This site also 
includes information about our complete portfolio of Data products.  
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ExchangeInfo Plus Product Guide 38 

 
 

1700 District Ave Ste 300 

Burlington, MA 01803-5231 

USA 

 

www.precisely.com  

 

Copyright 2015, 2022 Precisely 

 

http://www.precisely.com/

